如何在Kafka 0.10.1.0中使用Flink?


0

Flink支持Kafka 0.10.1.0吗?

我看到有一个flink-connector-kafka-0.10,但在flink的最新版本中我看不到它。

目前我正在使用

<dependency>
    <groupId>org.apache.flink</groupId>
    <artifactId>flink-connector-kafka-0.9_2.10</artifactId>
    <version>1.1.2</version>
</dependency>

2 答案


0

Flink的下一个小版本,flink1.2.0,将包含一个kafka0.10.x的 join器(参见JIRA问题)。

1.2.0的特性冻结发生在几天前。Flink1.2.0将在 test和社区投票后发布,有望在2017年1月发布。


0

目前,我正在运行Flink1.1.4和Kafka 0.10.0.0,使用Kafka join器0.9_2.10

<dependency>
        <groupId>org.apache.flink</groupId>
        <artifactId>flink-streaming-java_2.11</artifactId>
        <version>1.1.4</version>
        <scope>provided</scope>
    </dependency>

&lt;dependency&gt;
    &lt;groupId&gt;org.apache.flink&lt;/groupId&gt;
    &lt;artifactId&gt;flink-connector-kafka-0.9_2.10&lt;/artifactId&gt;
    &lt;version&gt;1.1.3&lt;/version&gt;
&lt;/dependency&gt;


我来回答

写文章

提问题

面试题